Auth modal not showing up anymore in app

Hello, we're currently having issues with the app not prompting the user for re-auth.
As far as we know, it was working normally before (few weeks prior).

We discovered this issue today, while changing our resource from OpenAPI to REST (created a new separate resource), and just copied/pasted the configs for all environments.

  • The resources contain the auth endpoint verification, and it works (sends 401 when invalid or no token and 200 after signing in)
  • tried this to both the old OpenAPI and the new REST resources
  • created a new app with one of each resource, a simple GET to a list of items, the auth prompt still doesn't show up (both when the query is triggered on page load or not)
  • tried looking at the our server logs, the auth check endpoint is NOT being called at all by retool, unless we call it directly (via direct query or by pressing the check auth button on the resource) but still, the auth modal doesn't show up
  • Using OAUTH 2.0

I looked through some of the other community discussions about this issue and it seems to be popping up from time to time, issues on both sides, so I tried making sure it isn't the usual suspects.

Also, a feature request would be to have a way that I can trigger a force re-auth for a specified resource when needed. (which was already asked before in here but no updates since)

Also, not sure how relevant this is but the app request returns 400, while the actual server request returns 401.

argg nevermind

I think this changed, maybe silently? over the course of the last few weeks but now the auth modal confirmation appears ONLY when vieweing the live version, not while previewing/editing the app.

Hey @william.cho! Sounds like you're potentially resolved, but also maybe seeing some unwanted changes with the auth modal? Is this affecting your development or your users? Happy to dig into this with you!