Apps do not use latest module version

Hello Retool!

I've edited one of our modules (https://tola.retool.com/apps/e744276c-7ca1-11ee-989d-6b8e0282c26e) but the updates are not reflected in apps that use this module. For example, this app (https://tola.retool.com/apps/3b410dd4-e271-11ec-b5cd-f7f5881249b0) does not reflect the latest changes to the module.

We have release versioning disabled, and my understanding is that apps should always load the latest module version. It has been 2 days since the module was last updated and the apps won't update. Please let me know if you need more information from me to troubleshoot this issue.

Thank you,
Nick Pozoulakis

2 Likes

To give more context to the retool team, this bug is across all our users.
We already tried suggested steps to validated this is not a cache issue :

  1. Check if there are any errors reported on the module changes you made. This may be unlikely, but worth a check.
  2. There could be a rare possibility of caching issues. You might want to clear your browser cache or try loading the app in incognito mode just to rule out this issue.
  3. Give a hard-refresh (Ctrl + F5 or Cmd + Shift + R) on the affected apps to make sure they are not loading old data from cache.

The weirdest thing about this bug is that if in editor mode I delete the Module and readds it, I can see that it is the latest version. But I refresh the editor mode or try to see if the changes have been applied to the real version of the app, it still shows the wrong one.

In the end to fix this, I duplicated the module and updated all APPs to use the new module.

+1 on this bug. We have recently downgraded to the free version, hence lost the release management, and the app is stuck on the latest release in the View mode.