All components dissapeared although they are listed

I made a complex form yesterday (spent some hours into it) and now the app just shows nothing, it is all blank. It is on the cloud retool solution. The componentes are still listed, but every is listed as having 0 keys.

Also i cannot add new componentes because they do not show up.

I tried:

  • Duplicating the app
  • Exporting to json and importing in another app
  • Opening it on incognito
  • Deleting cache

None of it has worked so far. I am afraid i have just lost all my work. It worries me more that this was my 2nd day using retool and this happened and i don't know if it can happen again...

I opened a support ticket but i'm trying to get help everywhere i can. Any help would be appreciated

We were able to get this resolved, but if anyone is encountering the same thing let us know here or please write into support!

For anyone having this issue. I found out the problem was due to a temporary state having an initial value whose value did not correspond with the operations made to it. The initial value was an object containing a number but when calling setValue a number was given. This, for some reason, made all the app go nuts and deleted the state of all the components.

My thanks to the retool team for helping me debug this using the query param ?historyOffset.