After recent update all our Auth broke?

We have been using Retool for nearly 6 months with no problems. Our Custom Auth worked fine for our resources with refresh. We never had any problems. Suddenly today, out of nowhere the Auth expired and we had to reauthorize everything. Many things still don't work. We haven't changed anything on our backend and all our auth code works fine outside of Retool. It's just in retool where the auths are getting messed up and not run properly. Presumably, there as some changes made in Retool which effected Custom Auth flows? We now have to run refresh manually for every single Custom Auth. It used to run automatically. So now our apps are unusable. There is nothing wrong with the Auth, because when we run it manually it works fine, but it never runs the refresh step anymore. This is a sudden change that just started happening this morning on Retool.

In our auth workflows, we used: environment.variables.SECRET without the {{}} as per the instructions. This ALWAYS worked. Today, we get an error that "environment" is not defined?? So we try retoolContext.configVars.NAME - but there is no configVars associated with retoolContext and so we can't access any of our envioronment variables in the auth workflows?? Seriously?? This is crazy. You made some change in Retool and broke all the Auth workflows and our apps are unusable now!

What's strange is that environment.variables.SECRET works perfectly fine in the 1st step of the Auth, but on the refresh step it is undefined? We have hard coded in the secret to test it and it works fine. How can environment.variables be available in Step 1 of an Auth workflow, but then undefined in the next step? And why was this working fine for 6 months and stopped working today, where the refresh step has no access to any environment variables?

So after significant testing, I can confirm that your workflow for creating authorization in a resource is totally broken. Suddenly, it is only possible to get environment variables, e.g. environment.variables.SECRET, in the Auth Workflow Step. However, these same environment variables are undefined Refresh auth workflow step, where environment is undefined. This is a breaking change that previously worked. It is now impossible to get access to environment variables in the Refresh auth workflow step in a workflow, rendering it impossible to create a working auth workflow, since you can never refresh anything, unless you do it manually. surprised nobody else has reported this, and I can only presume that nobody else uses a Refresh Auth Workflow with environment variables on Retool?

Hey @ddsgadget - Thanks for digging in and adding details here, we're investigating this on our side as we speak!

We just completed the rollback to revert to previous behavior as we work on a root cause, can you hard refresh any pages you have open and trigger the auth flow or test again to confirm on your side?

Thanks. Yes, after refreshing just now, I can confirm that everything works again.

Awesome, thanks for looping back! We're following up internally on what went wrong, and are working on a fix to the root cause. Feel free to tag me here if something around that seems off :smiley: