In case there's confusion about the index variable throw a linting error - that is actually expected, we have an internal ticket to address it since it has caused confusion for others before
There's more on using additionalScope in this post!
Out of curiosity, is there a particular reason you're not using the bulk update action type for this query?