While uploading a file to my s3 bucket api, its not uploading correct file object

I have an api which uploads files to the s3 bucket.
That api is working fine in Postman when I attach a file object in the body.
But the same behaviour is not working in retool.
I tried all the answers from many threads but still not working.
What I understood till now is that retool file object sends file data as a base64 but Postman sends it as binary.
Please help.

Why are you not using the s3 Resource configuration?

I am currently using the S3 component only.

But I am developing a single tenant admin panel where I will export json of the retool app I have built and will import it into the client retool account.

For uploading media into the retool app, I want to use my own S3 presigned URL instead of the S3 component to make my app independent of which retool client is using that retool app json.

Hi @atom369_42 have you tried a File type instead of Text?

Is file1 a file upload component? You may need to reference data from the .files property as well