Unable to unset old parameters for resource queries of OpenAPI type, when the spec changes

Hi, I'm having some troubles with openapi resources. Our rest api is under active development, and the openapi spec keeps changing frequently.

From the UI side, Retool picks up the change in the spec with no problem, but when I run the query, Retool sends an http request with all the old parameters not in the spec anymore (and not visible in the UI as well).

It seems it's not possible to unset these outdated parameters without recreating the query. Is this an issue that will be addressed?


Hey there :wave: Thanks for reaching out! Would you mind sending some query and resource screenshots if possible?

Sure, so below is a contrived example of the issue I'm having. I'll split it to 2 comments because it says I can't upload 5+ media resource per comment.

Here's the old spec: https://jsonkeeper.com/b/UVP2

It works just fine on Retool:

When I run the query I get the following:

Then the spec is updated: https://jsonkeeper.com/b/O2A6

On Retool this is what happens:

The Retool UI seems to have well adapted to the new spec but when I run the query,

'field1=value1' entry is still there and there doesn't seem to be a way for me to remove it, except recreating the query from scratch.

Hey @jeonghyeon.lee!

Thanks for the detailed write-up, this is super helpful! I was able to reproduce this bug on our end and have written up a bug report and linked it to this thread so we can keep you updated as our team makes progress on this. In the meantime, it seems like these params are tied to the individual instance of the query so duplicating it seems to clear the older params. I definitely understand how this can be suboptimal so hopefully, we will have a more permanent fix for this soon. Thanks for surfacing this!!

1 Like