Unable to move archived email to a new organization

Hello, I signed up for Retool with a personal email address through Google auth, which was then associated with a organization (Org1) for a collaborative project. I now want to transfer that email (Email1) to work on my own personal project within a different account (Org2) with a different retool subdomain.

In (Org1) my email address (Email1) was archived and I tried to "Sign Up" and create a new organization (Org2) with Google auth using the same email address (Email1). It just returns to the login screen. The URL is https://login.retool.com/auth/login?error=Validation%20error

I also tried creating an email/password login combination but was shown a blocking error "Name must be unique".

How can I now create a new organization with the email address I previously used and archived?

Hey @Adam_Jacobson!

It sounds like you might be running into a bug we have with our invite flow. In the meantime, I want to make sure you're unblocked!

Are you still unable to create that new organization with your original email?

Hi @victoria , yes, unfortunately I'm still having the same problem. I'm looking forward to building some personal apps, so any further help is appreciated.

Hi @victoria, to follow up, any chance my personal email address can be recognized as disassociated with the previous account, so that I can create a new one?

Okay, I think I've worked around this now by creating a new organization with an alternative email address and inviting the inactive email, then promoting it to admin.

Hey @Adam_Jacobson!

Apologies for the late reply here but glad you were able to get things resolved! For anyone else who stumbles across this thread we can update it when there's a more permanent fix for the bug!

This bug should now be fixed :slightly_smiling_face: If anyone is still having issues please let us know!