Slack connection problems

Hi there. I'm having difficulties connecting to slack using OAuth. I get a series of errors when selecting to connect with OAuth but the but the first error displayed is "redirect_uri did not match any configured URIs. Passed URI:". after this I'm given the opportunity to add the Retool app to slack but then the browser rejects a self-signed security certificate 'Kubernetes Ingress Controller Fake Certificate'. Any suggestions?

1 Like

Hey @faraday!

We just pushed a fix for a similar-looking issue. Are you still seeing these errors? If so would you mind posting screenshots of where you're seeing them?

Hi @Kabirdas . Thanks for responding. I've tried defining the resource again and it's gone through without an error - progress! However I have to confess that I'm still a bit in the dark as to how to use the new slack resource which is now created. For example - when setting up the resource the only info I'm asked for is a name. I'm not sure if this name is significant to the retool resource only or if it has meaning to slack. As far as slack is concerned how is the user and/or workspace defined? I tried setting up a retool workspace function to send a slack message (as shown below) without success but I assume it requires a lot more information than I'm providing. The slack api docs include a lot in information but I'm not sure what's relevant to the retool resouce. A simple example, or a list of setup steps would be helpful.

Good to hear it's working to this point!

When you authenticate the resource you should be able to specify the workspace you're giving the Retool Slack app access to:

Running a quick test it looks like the associated user is retool2

For the issue you're running into, can you try using the channel id and removing the double quotes from the string?

Hi @Kabirdas - all working fine now - thanks for your help with this.

Removing the quotes from the channel name seemed to be the main fix.