[self-hosted] how to disable automatic auth header for OpenAPI resources?

  • self-hosted on GKE
  • trying to setup OpenAPI resource based on a swagger YAML spec
  • noticed this note on the resources page

For OpenAPI, Retool will automatically add the OAuth 2.0 token as a header in each request. The header will have the following format: Authorization: Bearer OAUTH2_TOKEN. There is no additional configuration required. For more information and examples see our docs here.

  • it seems this header is being added to my request, in addition to my custom auth header
  • seems like this is confusing for the server and auth is rejected

=> is it possible to disable this automatic append of the Authorization header?

Hey @gabroo!

Custom auth has been made more widely available for self-hosted Retool orgs that are on version 3.4 or above, before then it's behind an experimental version flag. It sounds like that may help here as it should let you specify the header you need - what version are you on?