Running Retool under QNAP Docker

I’m a newbie to Retool but I like the things I’ve seen so far. I started testing on a Mac with Docker and it works great. With that said I like to move Retool to my QNAP server where I have the database I want to play with. Now I got into problems as the docker-compose file I’ve used on my Mac do not work on the QNAP. I’ve tested the official Retool image config from GitHub I do not get any result at all. Is there a possibility to run Retool on a QNAP server? Any tips?

Hey @Danielz are you trying to create a brand new deployment or are you trying to move over your current deployment to QNAP? How are you currently deployed?

I’ve tried to do a new clean employment without luck.

I used the docker-compose file as a base. I did change the path for the two files that’s needed to a place on the QNAP that’s reachable from the Docker. Still no luck.

The docker-compose file contains all containers so maybe separate the would be a better way forward.

But why not export all containers on another and import them into the QNAP server

What do you recommend?