Retool | IOS error

I have made a retool application, for some reason it is throwing errors on some IOS devices. It works perfectly fine on Android devices.

Retool App link -

A device details for some example/reference -
iPhone XS

iOS, v12


Screen Size
5.8 in - 2.79 x 5.65 in

1125 x 2436 px

375 x 812 dp

Aspect Ratio
19.5 : 9

Hi @lokeshdugarld!

I was able to load the page on my iPhone XR Safari browser. If you refresh the page or try opening it in Incognito, does it load?

Hey @victoria!! As I mentioned it is happening on some specific IOS devices only (all browsers chrome/safari). Try and check on iPhone 7 or iPhone XS.

I was able to test on an iPhone 7 and iPhone X (no XS available yet), and both seem to work! To double check, does it work on Incognito mode on mobile Chrome/Safari?

This is definitely reproducible. We run into the same issue as well. I tried this app the the original report shared, it's the same error.

Please try iPhone 11 OS 13.3 using Safari, Chrome, or Firefox.

1 Like

Aha! iPhone 11 did the trick—thank you @jdchen668!

@lokeshdugarld and @jdchen668, would it be alright if I stepped into either of your orgs to take a look at this app in editor mode to see if I can track down the issue? If so, would you also mind sharing your subdomain and app name?

Feel free to post here so we can dig into this with you on the side and then post the fix on this thread!

@victoria Any solution to this? I get this error using an iPod Touch running iOS 12.5.5. That's a pretty old version of iOS but later iOS versions aren't supported. I'm not even sure if the old iOS version is what's causing the problem but I would think Retool should still work on older devices, since it's browser-based.

Hi @fros! Ack, I'm afraid I have bad news for you. We only currently support iOs versions 13+. Supporting earlier versions is not currently on the roadmap unfortunately, but I've added you to an internal ticket requesting this.

It looks like you were able to reproduce the error using an iPhone 11 though?

Ah, that was for a specific app. Where are you getting this error? Is it in a specific app in your org? Did it ever work?

It happens anytime we attempt to login with Google. So there is no opportunity to select an app or anything.

That aligns with the internal bug report, which is specifically related to logging in on older iOS versions! It seems like some users (including myself when I tested) are able to log in with older iOS versions, but face issues in the app regardless.

1 Like

Gotcha, thanks