Prefix icons in select components are not displayed

I just noticed that prefix icons are not displayed in select components. As you see in the picture below an extra space is added before the selected value of the component, but the icon is not displayed (see examples "Kommunikations-kanal" and "Bundesland" in the screenshot). I tried this with choosing an icon directly or showing it based on conditions, same result. I also checked across my apps with the same issue arising. I have not encountered this problem with other components (see in comparison the text field "Postleitzahl" in the screenshot).

Would be great to see this fixed soon.

Thanks and best,

Hi @betternet!

This issue doesn't seem to be reproducing for me, is it still something you're seeing? If so, do you happen to have any org-level CSS in place?

Hi Kabirdas!
We do not have any preload CSS for all apps in place. I just checked and there was one CSS change in one of the apps where the issue occurs, but even after deleting this and clearing the cache the issue persists. (+ the issue is also there in apps where no local CSS change was made.)
In addition, I just noticed that prefix icons are also not shown to me in datetime fields.

I checked with:

  • Google Chrome Version 97.0.4692.99
  • Mozilla Firefox Version 96.0.3

Hi @betternet Thanks for these details! :thinking: Hmm, I'm also not able to reproduce this for our team.

Can you try an Incognito window in Chrome?

Also, can you share a screenshot of the right panel setup for one of these icons?

Hi Tess,

that's really odd. I just checked with Chrome in Incognito mode, same issue for me. I also encounter this issue across my devices and browsers.

Here are setups for two different component types. Note that I also tried this by adding the prefix icons directly instead of dynamically and I encountered the same issue:

  1. Datetime component:

  2. Select component:

Hi @betternet Thanks! It's still working for me in my app with this setup.

Are you using the Cloud version of Retool?

Yes, it is the Cloud version and I have just sent a message through the support chat. Beside the link to the app where the issue occurs I also added a link to this posting for reference.

Hi Tess, any news on this display bug and when it will be fixed? I'm currently holding back a release of new versions of some apps to customers due to this issue.

Hi @betternet,

Thanks for reaching out! I don't have a timeline from our internal team for this bug yet :disappointed:

In the meantime, would you be able to ship a release of your app without the background color or with a lower opacity background color?

1 Like

Hi @Tess as a workaround I have now turned the opacity to 56% (which by the way is the threshold for the sufix icon to be shown).

I nervetheless hope that this issue will be fixed soon.

Thank you!