OAUTH2.0 Troubleshooting

Hi everyone,

Rookie dev here. I'm running into trouble with configuring oauth2 - my hunch is that the issue has to do with the OAUTH2_TOKEN placeholder but I'm not 100% sure. I have this working as intended in Postman but not yet in Retool. Here is how I've configured the resource, followed by 2 error messages that I am seeing:

Error message #1. When I test the Authentication, I get this error message:


Error Message #2. When I ignore the above authentication message and simply attempt to run the query, I get this message from Retool:

Thanks in advance for any support you can provide!

Hi @maximus4133 ,

Have you tried placing the Authorization: Bearer OAUTH2_TOKEN as a header in the rest API resource you configured? Not sure if that is being picked up on the App side but the endpoint is literally referring to your token as OAUTH2_TOKEN instead of the token you are expecting. The error response confirms it as well.

The OAUTH2_TOKEN magic string should actually still get replaced when it's included on the app side! If that isn't the case let me know and we can investigate further.

It might be worth checking redirect uri in your fitbit application settings (mentioned here) to make sure that it matches https://oauth.retool.com/oauth/user/oauthcallback.