No variable appear when I use new variable with function in Query Library

Hello, when I build Query Library, there is no variable name appear in right panel when I use a variable with function. Here is example.

I have to add some extra unnecessary step to make it appear to work around this ,such as following:

Hi @AnsonHwang Thanks for reporting this! It's definitely strange :thinking:

I'm seeing the same issue:

As a hacky solution, it seems like changing the join part from .join(", ") to single quotes .join(', ') causes it to re-evaluate properly & enable the variable field:

thanks, the hack solution work. I think you should fix it. thanks.

@Tess Hi, I found my Function was resolved to variable today. I post this bug at following topic Function resolved to variable in Query Library

Is it caused by fixing this bug

Wonderful! I really didn't think my question into google was going to yield anything useful. That hack @Tess worked for me as well. I was trying to use .replaceAll() and was also losing the variable until changing " to '.

1 Like

Hi @AnsonHwang Unfortunately, that appears to be a separate issue with lack of support in the query library :disappointed: I'm not quite sure how it worked originally there, but it's not something that is expected to work

Glad to hear we could help, @shawncrocker !