Keep getting this from the retool application. Whats the fix here?

I repeatedly keep getting this error when I try to edit the properties of the component from the side panel. Please look into it on priority.


I also get this and similiar messages like the one below since yesterday (at least I was notified yesterday by users about it). Would be great to see this fixed as soon as possible as it causes quite some trouble in the organization I'm working with.

Hi @dheeraj! It looks like we broke renaming components, so I've alerted the on call team just now and will keep this thread updated with a fix.

And hi @betternet :blush: Does this error occur when renaming components as well, or is just from a separate action?

Hi Victoria,
no, I haven't changed the respective components (which are tables) in the last week. The error occurs already on page load, thus the tables are not loaded in the first place.
Best, Timo

Hmmm, that’s definitely strange. The initial bug reported (apps crashing when renaming components) was just fixed! :blush:

Are your tables still not loading? Do new tables load?

I just checked and it works right now again for the tables I was experiencing trouble before. Thank you!

Awesome! Thanks so much for confirming + glad the fix worked for you :blush:

1 Like

Unfortunatly the error returned for my apps. I get the following two messages for tables directly after page load:
-> "Error: Cannot use 'in' operator to search for 'rawValueFormatter' in undefined..."
-> "Error: Cannot read properties of undefined (reading 'formatter')..."

The issue occurs in different apps on differnt tables.

Hi @betternet, thank you for letting me know. If this is still occurring (we just had another table bug that got fixed), would it be alright for me to step into your app to take a look? If so, feel free to DM me a link to your app!

1 Like