Issue: The selected data source is empty or could not be converted to an array

Hi, I'm new to retool, and I'm just trying to build an app, which is getting data from Eurostat,

Would you please help me to understand how to solve this issue?


Hi, welcome,

The data you probably want to show is nested within your json result. Use query1.value as your data source and it would show a more useful table. Although I think it still wouldn’t look very good.

You may want to click Fx for the data source and use [{{}}] or use a transformer for the query and write formatDataAsArray(data) in the transformer
Screenshot 2023-07-25 at 10.56.48 AM

I don't think it is working

the error is gone, but still doesn't reflect the data into the table!

The data is at position

1 Like

Unfortunately the same issue!

Did you press the refresh button right next to columns, just below the primary key field? That should refresh the table columns from you dataset. Not sure how your table would look like with this data though. Probably a single row with multiple numbered columns.

I tried, but it's not active. I don't know why either :frowning:

Hey @tarek.atassi92!

What columns are you expecting to have in your table and what should the row values for each column look like?