Is this a bug? data undefined in selectedRow

Hello,

I have queries dependant on selectedRow(s) on a table component, as discussed here: WHERE IN filter based on.

When I load the page it seems a row is selected however my queries fail; data is undefined.

I enabled “Select the first row by default” and the row is highlighted on the frontend.
“Allow selecting multiple rows” is enabled too. (switching off does not help)

Is this a bug?

PS: clicking on the row fixes this

Hey @mm79! I think this relates to the “Allow selecting multiple rows” setting. Does it work if you toggle that off?

Unfortunately that’s not it, I just checked it.
However I do think it has something to do with the server side paginated setting. That’s one of the changes I made after it was working.

By the way: when I click the row the problem is solved and the other queries are finished immediately so it seems like the query has run and the result is cashed somehow. Nonetheless the other tables that are dependant on the selection load a couple of seconds and then return no results, which is kind of annoying.

Hm, still unable to repro. Could I trouble you to write into chat support via Intercom in your Retool app?

I’ll try some things myself first, I have some settings I want to check first; chatting might be tricky: when is chat support available?
Is an app file export a valid second option by the way?