Invalid Client on Google Sheets Resources

Im using Google sheets as one of my resources. It just went down just now and every action type I make, it always return “invalid_client”. Google sheet resource has been fully authorized and It was working perfectly fine an hour ago.

Anyone else experience the same problem?

1 Like

I’ve been working with Kelvin on this, it seems like it could have been a regional or account specific issue that resolved itself after a short while. We’re continuing to look into this, but if anyone else encounters the same error please let us know to help track down the cause!

5 Likes

Having the same problem here right now.

1 Like

+1-ing. Started running into this problem a few hours ago. I have a Retool app that queries a Google Sheet which had been working as recently as this morning (when I first loaded the app this morning). But it started returning invalid_client errors, even after deleting and recreating the Sheet resource.

Edit: Just tried with a different Google account + new spreadsheet, but seeing the same issue. Notably I don’t see the dropdown list of sheets in the Retool app anymore and have to use the raw ID option. Once I do that, I still get the invalid client error.

Same here. Seems to be a system wide issue. Pretty sure Retool will have it fixed in no time.

Any updates on this please?

Hi Everyone! We’re working on the issue now and will update this thread as we make progress!

@kelvin-reyes @grahamevans @colin @Crazydevil

This should be resolved now! We added another failover cluster today during the lower US holiday volume that was mishandling google sheets queries specifically. We’re working on additional tests to ensure this won’t happen again. Thank you all for the reports!

2 Likes

Excellent. Thanks @alex-w

1 Like