Hiding the border in a form component should also hide the floating action bar

When hiding the border in a form, it should also hide the bottom border in .retool-grid .retool-form-floating-action-bar (just above the submit button).


For now, I can do this using CSS:

.retool-grid .retool-container.retool-form-container.no-border .retool-form-floating-action-bar{

Thanks for all of the posts today @nacho, really keeping us on our toes :slight_smile:

I’m not sure that you’re 100% right here about what the default behavior should be (i.e. this is not a bug). What does your full app setup look like / why do you want this line removed?

Thanks, Justin. I think Retool is a great product and can become even better. :blush:

Form components have this setting, which I’ve turned off because my form lives inside a tabbed container and the extra lines make it look too busy:


Turning off this border should also turn off the line right on top of the submit button (otherwise, it looks weird just hanging in space).

Ah I meant a screenshot of your app, but nevermind, I get your POV here. I’ll create a ticket and share w/ the team :slight_smile:

Something like this:

1 Like