Form Button Disable from Checkbox Works in Module but not in App

I have the following simple user details form submission which I have created as a module:

The expected behaviour for this module looks as follows where selecting checkbox1 enables the submission button:

This all works fine within when editing and previewing the module itself. However, as soon as the module is used within an app, this functionality disappears:

Here are the parameters I have set for the form if this helps for context:

I have tried republishing the module. I have tried making a copy from scratch. Neither of these options seem to work.

Would be great to get some advice on this if anyone can reproduce.



If anyone could provide any support on this that would be great thanks - Ed

Hi @Edward_E!

Welcome to the forums :slight_smile: Happy to help here.

I just recreated a simple, similar setup on my end (form with checkbox in module in parent app) and it seems to be working for me. If you create a simple, similar setup, do you run into the same issue? If it's helpful, I attached a JSON of my module (that includes the form with a checkbox) for you to import into your org and test using in a parent app.

Let me know how that goes!

My module:

The module in my parent app: