Dataset was not found in location us

Even though I connected a BigQuery resource and got a successful test connection result, I can't run any queries against it ( I get Dataset dataset was not found in location US), and I don't get any autocomplete, or table suggestions in the gui mode. I double checked I have the region correct. Does anyone know what might be wrong?
I am using the form

FROM project-name.database.table;


FROM database.table;

@Ryan_Albertson Welcome to the forum!
Can you share some more information and screenshots with your set up and resource config?


Have tried removing the single quotes in the query?(See here) Also, check your Google settings to make sure you are in us-central1?

Yes I double checked I am in us-central1 (Iowa) according to the Google Cloud console. I am getting the same error without the backticks.

These are the databases according to my Cloud console

Sorry I meant to say remove the back ticks from the rest and leave them in the project ID like so:

  table_name, ddl
  table_name = 'population_by_zip_2010';

I just figured out that I was creating a database via Cloud SQL, but I think I have to instead create a dataset. Once I did that, I was able to get data to and from my dataset via the Retool resource.
Sorry about that confusion.
Thanks for your replies Scott

Happy you figured it out!