Custom-Auth with Salesforce

Hi there,

We have been using Retool for a few months now and would love to see the rest of our team use our apps.

We have been using the same salesforce resource so far, and this is now becoming a bottleneck as we would need 10 different people to access the same app, but each person should log in with their own salesforce details.

We have tried to set up a new resource using the "Use custom connected app" option, and the same error always appears when we try to log in using that new resource:


Would it be possible for someone to help us with that? We had a look at the documentation but can't really figure this out. Also checked the existing tickets on the forum and don't think it is matching with that issue. Hope this can help more people in the future too.

Many thanks

Hey @Jeje!

Can you check the callback URL you have set up in your Salesforce app? Retool uses a different callback URL depending on whether credentials are shared or not.

Shared credentials:

Individual credentials:

Thanks for coming back to me @Kabirdas - unfortunately that is currently set up properly so the issue might come from somewhere else.

@Jeje hmm.. it may be worth double checking that the consumer key and secret are correctly updated in Retool, otherwise I'm seeing this error come up as a timing issue so if you haven't tried it again for some time since your first test it might be worth checking again.

If those don't work would you mind sending over screenshots of your resource setup page and salesforce app setup page? If you rather not post them here you can do so in DMs or by writing to us in-app as well.