Copy/Paste bug - can't copy/paste right now in one App

I can't copy/paste right now in this one App. I have tried others and it is working.

If I select the first component and copy/paste (ctrl-c, ctrl-v) it while it is still selected, Retool hangs and I get this error in Chrome Dev Tools:

I have to reload the page.

1 Like

Hi @bradlymathews! Happy to dig into this with you. Are you copy+pasting a single component or is the item you're copy+pasting containing multiple or large components? Also, does the copy +paste work if you try it in a different browser? :thinking:

I very commonly experience issues with copy/paste, especially when its multiple components. Additionally I've noticed a severe performance issue when an app has a lot of copy/pasted items. I've built out a few apps using a lot of copy/paste had performance issues then rebuilt it from scratch and it works fine. Seems a bit wonky.

I've just stopped using it.

1 Like

Hey @stevenhdsdoor! Thanks for sharing your experience with us. Our team believes we have a solution for this and has a fix coming soon, but we want to make sure it's consistent with your scenario. Is there any chance you can share a screenshot of your app and what components you're trying to copy+paste or an export of your app? Feel free to email me at if you don't want to publicly expose anything from your app in this forum. :slightly_smiling_face:

It is when I copy and past anything, even a simple Text component.

I tried FF and I get the same hang (progress circle gif spins forever) and this error:

I copied the app and the corruption followed to the copy.

I exported the App and re-created from the JSON. The problem is still there.

1 Like

@Kenny I've been experiencing this as well when copy+pasting, as well as when trying to duplicate a component. This morning I tried duplicating a single number slider input

Screen Shot 2022-09-26 at 8.48.31 AM @bradlymathews @stevenhdsdoor

Our team just recently pushed out a fix for this yesterday on cloud, but let me know if you're still experiencing this when using the copy+paste!

Still broken for me. I did refresh my app a few times first.