Change row data type or spacific fields in table

Hi All

I have a table that pulls in various types of data from various resources.

The table below shows the current column headers.
The column data info comprises of Weather, 6 locations, and a total people count.


i would like to set the row for weather to display as temperature °c, the location rows as with a leading $ and 2 decimal points and the final count row as a standard number.

I can see the ability to add column types, for example i can make the Today column type Currency, but then that adds $ to the weather temperature and the people count.
If i set these columns as currency for ease of creation as more locations will be added later on can i change the specific weather and people cells to something otter than currency manually or can everything only be adjusted via column?
Is it possible to add to this query to add °c to the end of the inserted variable somehow?
I tried the following
{{,'°c' }},

However, the actual weather was removed for the °c

Any help would be greatly appreciated.


In the Mapped Value property in your column you could do a nested ternary along these line:

? self + 'c'
: currentRow.dataInfo==='People Count"
? self
: '$' + self }}

That looks at dataInfo column (the first one, whatever the actual column name is) and if it is a Weather row, the add the 'c'. Else it checks for People Count and puts the raw number. If neither of these it assumes a Location and adds the $.

Hey Mate.

Tried the code but sadly it throws a invalid or unexpected token error.

So i noticed on weather and people count that you lead with an apostraphe and end with a quotation, so i changed it to "Weather" and "People Count".

Table updated to show all rows with the leading $ including the weather and people count but at least no error.

Code currently looks like this

? self + 'c'
: currentRow.dataInfo==="People Count"
? self
: '$' + self }}


The means the logic is wrong and so it is defaulting the last option with is '$' + self.

Could be dataInfo is the wrong field name? I just guessed at that. Type the dot after currentRow and IntelliSense will tell you your available row names.

Thanks! Worked a treat.
Needed to use ['data info']

Any idea how to make the '$' + Self be set as currency with 2 decimal points?

'$' + self.toFixed(2) is what I use.

Worked a treat! thanks so much.