Can't Invite New Member

Seems like the Invite New Member functionality is not working for me. Possible bug?

I hadn't had any issues inviting team members until now. It's also possible that I'm doing something wrong, so apologies if that's the case.

Specifically, I tried sending invites to:

  1. A team member (@ourdomain.com account)
  2. Myself (@gmail.com account)
  3. Myself (@cs.stanford.edu account)

Option 3 worked, in the sense that I received the e-mail (though it was sent to spam) and the user appears as Invite pending in Setttings > Users.

Options 1 and 2 did not work, in the sense that the invite e-mails were not received (spam or otherwise) and the users don't appear as Invite pending in Setttings > Users.

I tried bulk add and individual add, and in both cases I get a Successfully added 0 users to n groups! message.

Hi @maurizio! We’re sending out a bug fix for this message soon, but it means that the email address that you were trying to invite already has created another retool account. We only support belonging to a single organization at a time for each unique email at the moment unfortunately

If you message in to the chat icon in the bottom right inside of Retool with the specific emails you are inviting, we can take a look and get this sorted out!

1 Like

Yup, that was exactly it. Thanks for the prompt response.

The error in this error message (error-ception :laughing:) should be fixed now!

Hi, I just encountered this issue (or a similar issue) too. I cannot invite a team member "name@ourdomain.com". I only get back "internal server error". Does my team member have to create a Retool account first and then I can invite them? My team member does not have a Retool account associated with that email.

Hello!

Thanks for writing in. They don't need to make an account in order to be invited. That typically happens upon accepting the invite. Is this a cloud user or an on-prem instance of Retool? Also, if you're not comfortable sharing their email, could you write into support via your app or support@retool.com?

Thank you!

John