Can't edit different environments anymore

I might be missing something, but after a recent update I can no longer edit different environment versions of a resource from within the Edit dialog in the editor, only production which is the default one. Any reason this was removed?

Also; I can no longer use preview {{ }} in my authentication flow?
edit it seems to be sent properly, just the preview is not working


Hey @Herge! I'll look into both of these to see if we regressed recently, thank you for the callouts :raised_hands:

1 Like

For your first point (editing a staging resource from within an app), this may be a regression so I just filed a ticket for it!

For your second point ( not previewing properly), do you remember when this last worked for you? And where in a resource is your screenshot from?

Thank you again for taking the time to write in :slight_smile:

1 Like

Thanks for the response @victoria!
The second screenshot is from within a custom request authentication flow step, inside the request body parameters. Last time the preview worked was around 2-3 weeks ago I think.

Super clear, thank you @Herge! Will keep you updated on the resolutions :crossed_fingers:

Update on your first point!

We re-added the ability to edit the staging environment from within an app's query :slight_smile: It should go live with our next Cloud deploy (which usually happens every few weekdays).

Thank you again for letting us know about this :pray: